Service maintenance updates will not apply ALTER EXTENSION UPDATE since the users code might depend on running the older version.

However, the new version of the extension is available for use.

You can check which extensions and versions are available with:

select * from pg_available_extensions;
Did this answer your question?